1 (18-01-2011 22:07:55 отредактировано JawsIk)

Тема: С каких версий Wp - Po Mo локализация?

Из-за того, что на форуме до сих пор нельзя написать полноценный заголовок в 70 русских символов, я напишу вопрос здесь:
С каких версия в WP появилось возможность локализации плагинов через *.po и *.mo файлы?

Просто я до сих пор сижу на WP2.3.3 (и скорее всего врятли её поменяю) и у меня как-то не работает.

Вот хотелось бы узнать с каких версий появилась возможность использовать *.po и *.mo файлы локализаций именно В ПЛАГИНАХ?

Сборка "Максовская" с этого ресурса и в самой сборке есть ru_RU.mo и ru_RU_lite.mo , но это я так понял для самого WP, а меня интересует именно для плагинов.

p.s. когда уже форум научится считать нормально 70 символов в заголовке? (я так понимаю касяк UTF8 и русских букв)

2

Re: С каких версий Wp - Po Mo локализация?

1.5.0

[signature]Есть ли смысл просить инструкцию по регулировке карбюратора, если не знаешь, в каком из багажников находится двигатель?[/signature]

3

Re: С каких версий Wp - Po Mo локализация?

О, приятно видеть в добром здравии старую гвардию.

Тогда странно, почему у меня ни один плагин не переводиться на версии 2.3.3 .

Может нужно какой-нить параметр ткнуть или где чего прописать?

4

Re: С каких версий Wp - Po Mo локализация?

0. Взаимно!

1. Должен быть включен язык  define ('WPLANG', 'ru_RU');
2. Где-то рядом с плагином должен быть его файлик my_plugin-ru_RU.mo
3. В самом плагине должен быть вызов load_plugin_textdomain('my_plugin')

Ни с именами файлов, ни с путями промахиваться нельзя, как Вы понимаете.

Матчасть Function Reference/load plugin textdomain « WordPress Codex

[signature]Есть ли смысл просить инструкцию по регулировке карбюратора, если не знаешь, в каком из багажников находится двигатель?[/signature]